Dashboard downtime
Incident Report for Loftware Cloud
Resolved
It was determined that a power event impacted a subset of storage racks in one of the Availability Zones in the West Europe region. This impacted storage/database tenants and network devices which may have rebooted. This resulted in the impact seen.

Mitigation: Most impacted resources automatically recovered following the power event through their automated recovery process. Microsoft monitored the health of impacted resources for an extended period and took manual steps for resources which didn’t automatically recover.
Posted Jan 18, 2023 - 09:40 UTC
Investigating
We noticed that NiceLabel cloud accounts were not working for some customers.
Posted Jan 18, 2023 - 08:20 UTC
This incident affected: West Europe (Dashboard, Document Storage, Print).