Signin problems with Microsoft accounts
Incident Report for NiceLabel Cloud
Resolved
Issues with login were fixed by Microsoft. In case any issue still persist with Label Cloud or client applications, please contact NiceLabel support (support@nicelabel.com).
Posted Mar 16, 2021 - 06:00 UTC
Identified
Microsoft identified an issue that caused this outage and is working on fixing it.
Posted Mar 15, 2021 - 21:28 UTC
Investigating
SUMMARY IMPACT: Starting at approximately 19:15 UTC on 15 Mar 2021, a subset of customers with connected Azure Active Directory may experience issues authenticating to Label Cloud and client applications.

CURRENT STATUS: Microsoft is aware of situation and are currently working on fixing it.
Posted Mar 15, 2021 - 19:15 UTC
This incident affected: West US (SignIn Site, Dashboard), South Central US (SignIn Site, Dashboard), West Europe (SignIn Site, Dashboard), Southeast Asia (SignIn Site, Dashboard), and North Europe (SignIn Site, Dashboard).