DNS issue impacting multiple Microsoft services
Incident Report for NiceLabel Label Cloud
Resolved
Microsoft DNS issues were resolved.

Below is the official statement from Microsoft:

Summary of Impact: Between approximately 21:30 UTC and 22:30 UTC on 01 Apr 2021, customers may have experienced intermittent issues accessing Microsoft services, including Azure, Dynamics, and Xbox Live.

Preliminary Root Cause: We are continuing to investigate the underlying cause for the DNS outage but we have observed that Microsoft DNS servers saw a spike in DNS traffic.

Mitigation: Microsoft engaged resilient DNS capabilities to absorb the spike in DNS traffic.
Posted Apr 01, 2021 - 22:30 UTC
Identified
Microsoft DNS issues prevented Label Cloud functionality from working.

Microsoft is investigating issue
Posted Apr 01, 2021 - 21:30 UTC
This incident affected: West US (SignIn Site, Dashboard, Document Storage, Print, Cloud Trigger, Cloud Print, Labeling Databases), South Central US (SignIn Site, Dashboard, Document Storage, Print, Cloud Trigger, Cloud Print, Labeling Databases), West Europe (SignIn Site, Dashboard, Document Storage, Print, Cloud Trigger, Cloud Print, Labeling Databases), North Europe (SignIn Site, Dashboard, Document Storage, Print, Cloud Trigger, Cloud Print, Labeling Databases), and Southeast Asia (SignIn Site, Dashboard, Document Storage, Print, Cloud Trigger, Cloud Print, Labeling Databases).